欢迎光临新疆SEO博客
我们一直在努力

windows 环境中 使用 composer报错 openssl错误笔记

 

大体意思就是composer要求使用openssl连接,百度相关问题,解决思路分为两种:

一、禁用openssl,结果是治标不治本放弃

二、开启php的openssl扩展,下载ca证书

具体操作如下:

1、开启php扩展,左键wamp-php-php扩展-php_openssl前面打勾。

2、在D:\phpstudy\php\php5.4.12(看个人安装路径确定)下找到php.ini文件,用sublime打开。

查找 extension=php_openssl.dll ,删除extension=php_openssl.dll前面的分号,取消注释,从而启用OpenSSL插件。

注意:因为SSL连接需要认证,所以继续下面的步骤之前,需要准备好CA证书(建议把证书保存到D:\wamp\wamp\bin\php\php5.4.12\verify目录中),可以从https://curl.haxx.se/docs/caextract.html处下载。(如果直接打开文件的话,另存为修改文件名即可)

3、如果php.ini文件中能够找到

;openssl.cafile=

和上面一样,去掉分号注释,设置CA证书为D:\phpstudy\php\php5.4.12\verify,即

openssl.cafile= “D:\phpstudy\php\php5.4.12\verify\cacert.pem”如果无法找到直接添加

openssl.cafile= “D:\phpstudy\php\php5.4.12\verify\cacert.pem”

完成上面操作再次在cmd环境中运行composer

update 问题解决,参考文章

未经允许不得转载:新疆SEO » windows 环境中 使用 composer报错 openssl错误笔记

分享到:更多 ()

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

新疆地区最专业的SEO优化方案提供商

新疆健康网